Talk:Installing BioPerl

From BioPerl
Jump to: navigation, search

Installing BioPerl-1.4 from the Bioperl 1.4 PPM3 archive at http://bioperl.org/DIST on a fresh install of 32-bit ActivePerl 5.8.8 Build 819 running under Windows XP Professional 64-bit edition results in the following error:

ERROR: Installing File-Spec-0.82 would downgrade File::Spec from version 3.12 to 0.82 and File::Spec::Functions from version 1.3 to 1.1 and File::Spec::Mac from version 1.4 to 1.2 and File::Spec::OS2 from version 1.2 to 1.1 and File::Spec::Unix from version 1.5 to 1.2 and File::Spec::VMS from version 1.4 to 1.1 and File::Spec::Win32 from version 1.6 to 1.2

This is using PPM 4 exactly according to instructions provided elsewhere in this wiki...

  • The BioPerl PPM4 directory was wrong. The new Release Candidates are in http://bioperl.org/DIST/RC. I have changed that on the wiki page. We will likely add the final 1.5.2 release to the regular PPM directory. Thanks for pointing that out! --Chris Fields 09:21, 4 November 2006 (EST)
  • There is only a PPM3 compatible PPD file for Bioperl 1.4 - I beleieve the above problem problem with PPM4 trying to be backward compatible and reading the old-style PPD files incorrectly. Since 1.4 is so out of date, the PPD for it will be removed and Windows users will only be able to install 1.5.2. -- Nath 03:57, 21 November 2006 (EST)
Personal tools
Namespaces
Variants
Actions
Main Links
documentation
community
development
Toolbox